re = /(?<!<[^>]*)\s(?<![^>]*<)(?=[^\s]*$)/
str = 'My custom text with <a href="#">a link<a/><span style="color: red;">.</span>'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result