#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<!<[^>]*)\s(?<![^>]*<)(?=[^\s]*$)"
Local $sString = "My custom text with <a href="#">a link<a/><span style="color: red;">.</span>"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)