using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!<[^>]*)\s(?<![^>]*<)(?=[^\s]*$)";
string substitution = @" ";
string input = @"My custom text with <a href=""#"">a link<a/><span style=""color: red;"">.</span>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}