const regex = /(?<!<[^>]*)\s(?<![^>]*<)(?=[^\s]*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!<[^>]*)\\s(?<![^>]*<)(?=[^\\s]*$)', 'g')
const str = `My custom text with <a href="#">a link<a/><span style="color: red;">.</span>`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);