$re = '/(?<!<[^>]*)\s(?<![^>]*<)(?=[^\s]*$)/';
$str = 'My custom text with <a href="#">a link<a/><span style="color: red;">.</span>';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;