use strict;
my $str = 'My custom text with <a href="#">a link<a/><span style="color: red;">.</span>';
my $regex = qr/(?<!<[^>]*)\s(?<![^>]*<)(?=[^\s]*$)/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";