#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\W\d_]+(?:_[^\W\d_]+)*$"
Local $sString = "sss" & @CRLF & _
"fff_fff" & @CRLF & _
"f_f_f_f" & @CRLF & _
"sss_" & @CRLF & _
"sss@" & @CRLF & _
"sss#" & @CRLF & _
"sss$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")