using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\W\d_]+(?:_[^\W\d_]+)*$";
string input = @"sss
fff_fff
f_f_f_f
sss_
sss@
sss#
sss$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}