re = /^[^\W\d_]+(?:_[^\W\d_]+)*$/m
str = 'sss
fff_fff
f_f_f_f
sss_
sss@
sss#
sss$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end