// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\W\d_]+(?:_[^\W\d_]+)*$").unwrap();
let string = "sss
fff_fff
f_f_f_f
sss_
sss@
sss#
sss$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}