const regex = /^[^\W\d_]+(?:_[^\W\d_]+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\W\\d_]+(?:_[^\\W\\d_]+)*$', 'gm')
const str = `sss
fff_fff
f_f_f_f
sss_
sss@
sss#
sss\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}