$re = '/^[^\W\d_]+(?:_[^\W\d_]+)*$/m';
$str = 'sss
fff_fff
f_f_f_f
sss_
sss@
sss#
sss$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);