package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\W\d_]+(?:_[^\W\d_]+)*$`)
var str = `sss
fff_fff
f_f_f_f
sss_
sss@
sss#
sss$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}