#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]\(|or"
Local $sString = "C" & @CRLF & _
"A" & @CRLF & _
"T" & @CRLF & _
"G" & @CRLF & _
"CC" & @CRLF & _
"KEEP" & @CRLF & _
"ATC" & @CRLF & _
"CACACAC" & @CRLF & _
"CCCCCCCCACAGTTTATGTAG" & @CRLF & _
"C(2" & @CRLF & _
"Cor CC" & @CRLF & _
"AC or ACC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")