re = /^[A-Z]\(|or/m
str = 'C
A
T
G
CC
KEEP
ATC
CACACAC
CCCCCCCCACAGTTTATGTAG
C(2
Cor CC
AC or ACC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end