package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]\(|or`)
var str = `C
A
T
G
CC
KEEP
ATC
CACACAC
CCCCCCCCACAGTTTATGTAG
C(2
Cor CC
AC or ACC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}