import re
regex = re.compile(r"^[A-Z]\(|or", flags=re.MULTILINE)
test_str = ("C\n"
"A\n"
"T\n"
"G\n"
"CC\n"
"KEEP\n"
"ATC\n"
"CACACAC\n"
"CCCCCCCCACAGTTTATGTAG\n"
"C(2\n"
"Cor CC\n"
"AC or ACC")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")