import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]\\(|or";
final String string = "C\n"
+ "A\n"
+ "T\n"
+ "G\n"
+ "CC\n"
+ "KEEP\n"
+ "ATC\n"
+ "CACACAC\n"
+ "CCCCCCCCACAGTTTATGTAG\n"
+ "C(2\n"
+ "Cor CC\n"
+ "AC or ACC";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}