// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]\(|or").unwrap();
let string = "C
A
T
G
CC
KEEP
ATC
CACACAC
CCCCCCCCACAGTTTATGTAG
C(2
Cor CC
AC or ACC";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}