$re = '/^[A-Z]\(|or/m';
$str = 'C
A
T
G
CC
KEEP
ATC
CACACAC
CCCCCCCCACAGTTTATGTAG
C(2
Cor CC
AC or ACC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);