#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "there is an audit log entry for user (\w*)?(?: with DA logType) ?(Pending|Approved)?"
Local $sString = "there is an audit log entry for user maker with DA logType Approved"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")