re = /there is an audit log entry for user (\w*)?(?: with DA logType) ?(Pending|Approved)?/
str = 'there is an audit log entry for user maker with DA logType Approved'
# Print the match result
str.match(re) do |match|
puts match.to_s
end