const regex = /there is an audit log entry for user (\w*)?(?: with DA logType) ?(Pending|Approved)?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('there is an audit log entry for user (\\w*)?(?: with DA logType) ?(Pending|Approved)?', '')
const str = `there is an audit log entry for user maker with DA logType Approved`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}