import Foundation
let pattern = #"there is an audit log entry for user (\w*)?(?: with DA logType) ?(Pending|Approved)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"there is an audit log entry for user maker with DA logType Approved"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}