using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"there is an audit log entry for user (\w*)?(?: with DA logType) ?(Pending|Approved)?";
string input = @"there is an audit log entry for user maker with DA logType Approved";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}