// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"there is an audit log entry for user (\w*)?(?: with DA logType) ?(Pending|Approved)?").unwrap();
let string = "there is an audit log entry for user maker with DA logType Approved";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}