import re
regex = re.compile(r"there is an audit log entry for user (\w*)?(?: with DA logType) ?(Pending|Approved)?")
test_str = "there is an audit log entry for user maker with DA logType Approved"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")