#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s+\d+\/\d+\w*g$"
Local $sString = "Cashew Alm Classic 6/200g" & @CRLF & _
"Cashew Buttery Sprd 8/227g" & @CRLF & _
"Chives&Garlic 6/98g"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)