// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s+\d+\/\d+\w*g$").unwrap();
let string = "Cashew Alm Classic 6/200g
Cashew Buttery Sprd 8/227g
Chives&Garlic 6/98g";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}