package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+\d+\/\d+\w*g$`)
var str = `Cashew Alm Classic 6/200g
Cashew Buttery Sprd 8/227g
Chives&Garlic 6/98g`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}