import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+\\d+\\/\\d+\\w*g$";
final String string = "Cashew Alm Classic 6/200g\n"
+ "Cashew Buttery Sprd 8/227g\n"
+ "Chives&Garlic 6/98g";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}