$re = '/\s+\d+\/\d+\w*g$/m';
$str = 'Cashew Alm Classic 6/200g
Cashew Buttery Sprd 8/227g
Chives&Garlic 6/98g';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;