import Foundation
let pattern = #"\s+\d+\/\d+\w*g$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Cashew Alm Classic 6/200g
Cashew Buttery Sprd 8/227g
Chives&Garlic 6/98g
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)