#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,12}(?:\.\d{1,2})?$"
Local $sString = "100000000000" & @CRLF & _
"000000000000" & @CRLF & _
"999999999999" & @CRLF & _
"999999999999.a" & @CRLF & _
"999999999999.1" & @CRLF & _
"999999999999.22" & @CRLF & _
"2999999999999.22" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")