$re = '/^\d{1,12}(?:\.\d{1,2})?$/m';
$str = '100000000000
000000000000
999999999999
999999999999.a
999999999999.1
999999999999.22
2999999999999.22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);