import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,12}(?:\\.\\d{1,2})?$";
final String string = "100000000000\n"
+ "000000000000\n"
+ "999999999999\n"
+ "999999999999.a\n"
+ "999999999999.1\n"
+ "999999999999.22\n"
+ "2999999999999.22\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}