using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,12}(?:\.\d{1,2})?$";
string input = @"100000000000
000000000000
999999999999
999999999999.a
999999999999.1
999999999999.22
2999999999999.22
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}