re = /^\d{1,12}(?:\.\d{1,2})?$/m
str = '100000000000
000000000000
999999999999
999999999999.a
999999999999.1
999999999999.22
2999999999999.22
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end