// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,12}(?:\.\d{1,2})?$").unwrap();
let string = "100000000000
000000000000
999999999999
999999999999.a
999999999999.1
999999999999.22
2999999999999.22
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}