#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*:(?s).*?(?=\bAnd\b|$)"
Local $sString = "And we validate that the following occurrences for event 123456 and source PLAYER are saved in Database:" & @CRLF & _
"| PLAYER | GAME | " & @CRLF & _
"| 1 | FOOTBALL |" & @CRLF & _
"" & @CRLF & _
"And we validate that the following messages for event 123456 and source PLAYER are sent in Other Database:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")