$re = '/.*:(?s).*?(?=\bAnd\b|$)/';
$str = 'And we validate that the following occurrences for event 123456 and source PLAYER are saved in Database:
| PLAYER | GAME |
| 1 | FOOTBALL |
And we validate that the following messages for event 123456 and source PLAYER are sent in Other Database:';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);