import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*:(?s).*?(?=\\bAnd\\b|$)";
final String string = "And we validate that the following occurrences for event 123456 and source PLAYER are saved in Database:\n"
+ "| PLAYER | GAME | \n"
+ "| 1 | FOOTBALL |\n\n"
+ "And we validate that the following messages for event 123456 and source PLAYER are sent in Other Database:";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}