using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*:(?s).*?(?=\bAnd\b|$)";
string input = @"And we validate that the following occurrences for event 123456 and source PLAYER are saved in Database:
| PLAYER | GAME |
| 1 | FOOTBALL |
And we validate that the following messages for event 123456 and source PLAYER are sent in Other Database:";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}