re = /.*:(?s).*?(?=\bAnd\b|$)/
str = 'And we validate that the following occurrences for event 123456 and source PLAYER are saved in Database:
| PLAYER | GAME |
| 1 | FOOTBALL |
And we validate that the following messages for event 123456 and source PLAYER are sent in Other Database:'
# Print the match result
str.match(re) do |match|
puts match.to_s
end