import Foundation
let pattern = #".*:(?s).*?(?=\bAnd\b|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
And we validate that the following occurrences for event 123456 and source PLAYER are saved in Database:
| PLAYER | GAME |
| 1 | FOOTBALL |
And we validate that the following messages for event 123456 and source PLAYER are sent in Other Database:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}