#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+)\s(Yanvar|Fevral|Mart|Aprel|May|İyun|İyul|Avqust|Sentyabr|Oktyabr|Noyabr|Dekabr)"
Local $sString = "1 Yanvar" & @CRLF & _
"2 Fevral" & @CRLF & _
"3 Mart" & @CRLF & _
"4 Aprel" & @CRLF & _
"5 May" & @CRLF & _
"6 İyun" & @CRLF & _
"7 İyul" & @CRLF & _
"8 Avqust" & @CRLF & _
"9 Sentyabr" & @CRLF & _
"10 Oktyabr" & @CRLF & _
"11 Noyabr" & @CRLF & _
"12 Dekabr"
Local $sSubst = "$1 \L$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)