using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)\s(Yanvar|Fevral|Mart|Aprel|May|İyun|İyul|Avqust|Sentyabr|Oktyabr|Noyabr|Dekabr)";
string substitution = @"$1 \L$2";
string input = @"1 Yanvar
2 Fevral
3 Mart
4 Aprel
5 May
6 İyun
7 İyul
8 Avqust
9 Sentyabr
10 Oktyabr
11 Noyabr
12 Dekabr";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}