use strict;
my $str = '1 Yanvar
2 Fevral
3 Mart
4 Aprel
5 May
6 İyun
7 İyul
8 Avqust
9 Sentyabr
10 Oktyabr
11 Noyabr
12 Dekabr';
my $regex = qr/(\d+)\s(Yanvar|Fevral|Mart|Aprel|May|İyun|İyul|Avqust|Sentyabr|Oktyabr|Noyabr|Dekabr)/mp;
my $subst = '$1 \\L$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";