// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)\s(Yanvar|Fevral|Mart|Aprel|May|İyun|İyul|Avqust|Sentyabr|Oktyabr|Noyabr|Dekabr)").unwrap();
let string = "1 Yanvar
2 Fevral
3 Mart
4 Aprel
5 May
6 İyun
7 İyul
8 Avqust
9 Sentyabr
10 Oktyabr
11 Noyabr
12 Dekabr";
let substitution = "$1 \\L$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}