import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)\\s(Yanvar|Fevral|Mart|Aprel|May|İyun|İyul|Avqust|Sentyabr|Oktyabr|Noyabr|Dekabr)";
final String string = "1 Yanvar\n"
+ "2 Fevral\n"
+ "3 Mart\n"
+ "4 Aprel\n"
+ "5 May\n"
+ "6 İyun\n"
+ "7 İyul\n"
+ "8 Avqust\n"
+ "9 Sentyabr\n"
+ "10 Oktyabr\n"
+ "11 Noyabr\n"
+ "12 Dekabr";
final String subst = "$1 \\L$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}